False Alerts via SearchStax Pulse
Incident Report for SearchStax
Resolved
Our team has enhanced the existing functionality to simplify how SearchStax defines and handles Heartbeat alerts to avoid false positives.

These changes involve monitoring failures for a complete time window that is defined by the user. Along with those changes, our team made infrastructure changes to separate SearchStax Pulse from SearchStax Management Service, reducing one having an adverse impact on another.

As we are marking this incident as resolved, the manual processes put in place as mentioned in this incident log earlier are being removed. After today, if you encounter any false positives, please contact us at support@searchstax.com.
Posted Dec 09, 2019 - 20:57 PST
Investigating
Starting 10:10pm PST, our team noticed a large number of errors in Heartbeat detection for deployments for the alerts setup via SearchStax Pulse.

At this time, we checked all alerts triggered via Pulse and have confirmed that the deployments for which these alerts were triggered are all in healthy state.

We have temporarily paused the alert emails while we investigate the issues.

Our team has separate monitoring that is setup for all deployments for which they get alerted on if a node or deployment is unavailable. If you are one of our Premium Customers, and if we encounter any issue, our team will reach out to you via email.

As there is more progress on the issue, we will keep updating this incident.
Posted Oct 10, 2019 - 22:49 PDT
This incident affected: SearchStax Cloud (SearchStax Cloud Admin App).