Expired AddTrust External CA Root Certificate
Incident Report for SearchStax
Resolved
This incident has been resolved.
Posted Jul 18, 2020 - 09:12 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 30, 2020 - 10:01 PDT
Identified
On May 30, 2020 the commonly used Sectigo (Comodo) Root certificate, named the AddTrust External CA Root has expired.

More information about this can be found here:
https://support.sectigo.com/Com_KnowledgeDetailPage?Id=kA03l00000117WR#Q2

As the article explains, there is no extra action required on the server-side. However, if your application is having issues connecting, please contact us at support@searchstax.com and we can remove the certificate from the chain.
Posted May 30, 2020 - 09:20 PDT